Ecommerce Shopify WordPress Discussion

Widget "Archive Posts" doesn't pull posts on the homepage

Good afternoon, everyone! I have a question regarding WordPress, and I would greatly appreciate it if someone could help me out. Here's the situation: I created an archive in the Elementor Theme Builder for my blog posts. During the creation process, I used the Archive Posts widget, and it successfully displayed all the test posts I had made. However, when I use this widget (Archive Posts) on my homepage, it doesn't retrieve the blog posts. Instead, it pulls a version of my homepage in card format. I appreciate any assistance you can provide! I tried watching the tutorial on how the archive works, but it didn't work.
TurboCommerce make the better internet purchasing globaly

Turbo Multi-language Translator

Make the better internet purchasing globaly

Turbosify SEO Speed Booster

5.0 (7) Free plan available
Get better conversions by improving store loading speed Installed

Turbo Multi-language Chat - AI Customer service in one hand

TurboCommerce make the better internet purchasing globaly
Our products

The help you need, when you need it

App by Turbo Engine

3 apps • 5.0 average rating

Turbosify Speed Booster

5.0 (7)
Get better conversions by optimizing shopify store Google page speed Installed

Turbosify Translator for Wordpress Woocommerce

5.0 (74) Free Wordpress Woocommerce Plugin
Translate your wordpress website to multiple language within 1 click, no configuration needed, no No technical required

Grow your business here

Whether you want to sell products down the street or around the world, we have all the tools you need.