Ecommerce Shopify WordPress Discussion

Multilingualpress error – Undefined constant

I recently set up a local working environment for building websites on my Mac, using Valet (https://laravel.com/docs/10.x/valet). At the moment, everything seems to be functioning correctly, except for an error I'm encountering in the Multilingualpress plugin: [24-Dec-2023 10:24:43 UTC] PHP Fatal error: Uncaught Error: Undefined constant "Inpsyde\MultilingualPress\Framework\Http\INPUT_REQUEST" in /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/src/framework/Http/PhpServerRequest.php:81 Stack trace: #0 /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/src/multilingualpress/Core/ServiceProvider.php(664): Inpsyde\MultilingualPress\Framework\Http\PhpServerRequest->bodyValue('') #1 /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/src/multilingualpress/Core/ServiceProvider.php(646): Inpsyde\MultilingualPress\Core\ServiceProvider->bootstrapCore(Object(Inpsyde\MultilingualPress\Framework\Service\Container)) #2 /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/src/framework/Service/ServiceProvidersCollection.php(70): Inpsyde\MultilingualPress\Core\ServiceProvider->bootstrap(Object(Inpsyde\MultilingualPress\Framework\Service\Container)) #3 /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/src/multilingualpress/MultilingualPress.php(91): Inpsyde\MultilingualPress\Framework\Service\ServiceProvidersCollection->applyMethod('bootstrap', Object(Inpsyde\MultilingualPress\Framework\Service\Container)) #4 /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/multilingualpress.php(198): Inpsyde\MultilingualPress\MultilingualPress->bootstrap() #5 /Users/sam/Code/vivafloors/wp/wp-includes/class-wp-hook.php(310): Inpsyde\MultilingualPress\bootstrap('') #6 /Users/sam/Code/vivafloors/wp/wp-includes/class-wp-hook.php(334): WP_Hook->apply_filters(NULL, Array) #7 /Users/sam/Code/vivafloors/wp/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #8 /Users/sam/Code/vivafloors/wp/wp-settings.php(495): do_action('plugins_loaded') #9 /Users/sam/Code/vivafloors/wp/wp-config.php(183): require_once('/Users/sam/Code...') #10 /Users/sam/Code/vivafloors/wp/wp-load.php(50): require_once('/Users/sam/Code...') #11 /Users/sam/Code/vivafloors/wp/wp-blog-header.php(13): require_once('/Users/sam/Code...') #12 /Users/sam/Code/vivafloors/wp/index.php(17): require('/Users/sam/Code...') #13 /Users/sam/.composer/vendor/laravel/valet/server.php(110): require('/Users/sam/Code...') #14 {main} thrown in /Users/sam/Code/vivafloors/wp/wp-content/plugins/multilingualpress/src/framework/Http/PhpServerRequest.php on line 81 My client is currently using an older version of MultilingualPress (v3.3.2) due to the absence of a yearly license requirement at the time of purchase. The current yearly license for 3 sites starts at $299, which is beyond the budget for my client. The website functions seamlessly on the live server, and the PHP version locally matches that of the live server (7.4). I suspect there may be a configuration setting in my local server environment causing this issue. Despite extensive research, I have not found relevant information to resolve the error. I was hopeful that someone might recognize the error or identify a server setting that requires adjustment.
Our products

The help you need, when you need it

App by Turbo Engine

3 apps • 5.0 average rating

Turbosify Speed Booster

5.0 (7)
Get better conversions by optimizing shopify store Google page speed Installed

Turbosify Translator for Wordpress Woocommerce

5.0 (74) Free Wordpress Woocommerce Plugin
Translate your wordpress website to multiple language within 1 click, no configuration needed, no No technical required

Grow your business here

Whether you want to sell products down the street or around the world, we have all the tools you need.