Ecommerce Shopify WordPress Discussion

Could not resolve dependency: peer vite@"^4.0.4" from vite-plugin-shopify@2.2.1

I'm trying to use vite-plugin-shopify plugin on my shopify theme. My vite version is 5.0.7 but to work with the plugin it's saying me to downgrade it to 4.0.4. Should I use --force option with my current vite version? Or, downgrade my vite version? Which will be appropriate option? I tried the npm i --force vite-plugin-shopify -D and then it warned me.
TurboCommerce make the better internet purchasing globaly

Turbo Multi-language Translator

Make the better internet purchasing globaly

Turbosify SEO Speed Booster

5.0 (7) Free plan available
Get better conversions by improving store loading speed Installed

Turbo Multi-language Chat - AI Customer service in one hand

TurboCommerce make the better internet purchasing globaly
Our products

The help you need, when you need it

App by Turbo Engine

3 apps • 5.0 average rating

Turbosify Speed Booster

5.0 (7)
Get better conversions by optimizing shopify store Google page speed Installed

Turbosify Translator for Wordpress Woocommerce

5.0 (74) Free Wordpress Woocommerce Plugin
Translate your wordpress website to multiple language within 1 click, no configuration needed, no No technical required

Grow your business here

Whether you want to sell products down the street or around the world, we have all the tools you need.